Spire.Doc is a professional Word .NET library specifically designed for developers to create, read, write, convert and print Word document files from any .NET platform (C#, VB.NET, ASP.NET, .NET Core) and Java applications (J2SE and J2EE) with fast and high quality performance.

Thu Jan 10, 2013 12:07 pm

I have an issue when converting an RTF input to a docx. It usually works, however when using bulletpoints in the text it will hit return the error “Object reference not set to an instance of an object.”

I have attached the RTF editor and the code it executes to convert the document to this post.

Please could you advise me whether I am using the component incorrectly or if this is something you could resolve?

If you need any more information on this issue, please let me know.
Thank you.

Kind Regards
D
You do not have the required permissions to view the files attached to this post.

dgaminger
 
Posts: 13
Joined: Wed Jan 09, 2013 5:04 pm

Fri Jan 11, 2013 8:14 am

Hello dgaminger,

Thanks for your inquiry.
We are sorry that we don't completely understand your problem. Is your problem that converting an RTF which doesn't contain bulletpoints to a docx will work and converting an RTF which contains bulletpoints to a docx doesn't work?
Does poByteArray object in the code poByteArray = enc.GetBytes(rtbEditor.Rtf); contain bulletpoints?
If it does, please save poByteArray to a .bin file and provide us the .bin file, just as the code which be marked as yellow in the attachment. So that we can reproduce your problem and solve it soon. Thank you!

Best regards,
Amy
E-iceblue support team
You do not have the required permissions to view the files attached to this post.
User avatar

amy.zhao
 
Posts: 2328
Joined: Wed Jun 27, 2012 8:50 am

Fri Jan 11, 2013 12:19 pm

Hi Amy,

Indeed, I only experience the issue when I try to include bulletpoints in my RTF input.

I have attached the temp.bin file.

Hope you can help.

Kind Regards
Doris
You do not have the required permissions to view the files attached to this post.

dgaminger
 
Posts: 13
Joined: Wed Jan 09, 2013 5:04 pm

Mon Jan 14, 2013 7:04 am

Hello Doris,

Thanks for your file.
We are sorry for the delay response for the weekends here.
We have reproduced your problem. We are sorry for the inconvenience. We have posted it to our dev team. They will do some researches and fix it. We will inform you immediately as soon as the problem has been fixed.

Best regards,
Amy
E-iceblue support team
User avatar

amy.zhao
 
Posts: 2328
Joined: Wed Jun 27, 2012 8:50 am

Mon Jan 14, 2013 1:38 pm

Thanks for all your help Amy :)

dgaminger
 
Posts: 13
Joined: Wed Jan 09, 2013 5:04 pm

Thu Jan 17, 2013 10:07 am

Hello Doris,

We have fixed your problem. Please download Spire.Doc Pack (Hot Fix) Version:4.6.9(the link is http://www.e-iceblue.com/Download/download-word-for-net-now/spiredoc-pack-hot-fix469.html?Itemid=0) and tell us your test result. Thank you!
If you encounter any problem, please feel free to contact us.

Best regards,
Amy
E-iceblue support team
User avatar

amy.zhao
 
Posts: 2328
Joined: Wed Jun 27, 2012 8:50 am

Return to Spire.Doc