Error Loading an HTML file

Technical support for Spire.Doc

Moderator: iceblue support

Error Loading an HTML file

Postby lbassil » Sat Oct 15, 2011 11:34 pm

Hello All,

I am using the Spire.Doc in order to create an html file out of a word document, so by just converting the word document to HTML following the sample provided in the demo of this site. However, if I try to reopen the resultant html file, I get the following error: The required attribute 'alt' is missing.

I believe that the tool should at least be able to open the html file it creates. Note that the word document contained an image, this is why the alt error gets generated. How can I solve this issue? I need to be able to open the html file and display it on the browser.

Your help is much appreciated.

Regards.
lbassil
 
Posts: 4
Joined: Sat Oct 15, 2011 11:27 pm

Re: Error Loading an HTML file

Postby Tina.Lin » Mon Oct 17, 2011 6:42 am

Hello lbassil,

Sorry for any inconveniences caused by us and thank you for your patience with our reply.

If you want to load a html file which is out of word file, you can reopen the html file like this:
document.LoadFromFile(@"..\..\WordToHtml.html", FileFormat.Html, XHTMLValidationType.None);
if you still have any questions, please don’t hesitate to contact us.
Have a nice day.
BR
Tina
Technical Support/Developer,
e-iceblue Support Team
User avatar
Tina.Lin
 
Posts: 152
Joined: Tue Sep 13, 2011 5:37 am


Return to Spire.Doc

Who is online

Users browsing this forum: No registered users and 1 guest